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QUICK START NOTES

Included is the SIS Thermal Desorption software version 1.2.0 (2014-02-26) supporting the SIS TD5 (single-shot) and
SIS AutoDesorb 2000 (multi-sample) thermal desorption systems for volatile and semi-volatile analysis.

Manuals and Documentation provided include

• TD5 User Manual [PDF]

• AutoDesorb Install [PDF]

• AutoDesorb Operation [PDF]

• SIS Thermal Desorption Software Documentation (page 1) (Windows Help File or [PDF]) (for both TD-5 and
AutoDesorb)

Further documentation is available on our web site: www.sisweb.com/sptd1

• product info

• application notes - dozens of papers and articles on applying the thermal desorption technique

• adsorbent resins data - extensive breakthrough volume data per resin, compound, and temperature

• supplies - tubes, needles, absorbents, cryo-traps, conditioning ovens, purge & trap, sampling systems, ...

Installation procedures are described in the hardware manuals and this software manual (Software Installation
(page 15)).

Startup of the TD software will occur automatically when your GC data system is started if the TD software is
integrated with Agilent ChemStation or MassHunter. Otherwise, you start the SIS Thermal Desorption Program from
the Windows Start menu.

Support

For assistance (phone/e-mail/on-site), please contact SIS. Phone: 1-(908)-788-5550, Fax: 1-(908)-806-6631, E-mail:
www.sisweb.com/contact.htm2 Home Page: www.sisweb.com3

1http://www.sisweb.com/sptd
2http://www.sisweb.com/contact.htm
3http://www.sisweb.com
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About the Manual

This manual covers the installation and operation of the SIS Thermal Desorption Software for the SIS TD-5 and
AutoDesorb thermal desorption systems.

The information in this manual is provided with the assumption that the user is familiar with general gas chromatog-
raphy (GC) concepts and the operation of the instrument on which the thermal desorption system is installed. Refer to
the manuals supplied by the manufacturer of your GC for specifics on your GC and GC data system software.

Additional information can be found on the thermal desorption section of the SIS web site: www.sisweb.com/sptd4

. This includes product information, application notes, and adsorbent resins data. Please let us know if anything is
unclear or could be improved in this manual.

0.1 Notice

The information contained in this document is subject to change without notice.

Scientific Instrument Services (S.I.S.) makes no warranty of any kind with regard to the material contained in this
manual, including, but not limited to, the implied warranties of merchantability and fitness of the equipment and
techniques therein described for a particular purpose.

S.I.S. shall not be liable for errors contained herein or for incidental or consequential damages in connection with the
furnishing, operation, performance or use of the SIS Short Path Thermal Desorption System described in this manual.

S.I.S. assumes no responsibility for the use or reliability of its equipment that is not furnished by S.I.S.

This document contains proprietary information which is protected by copyright and patents. All rights are reserved.
No part of this document may be photocopied, reproduced or translated to another language without the prior written
consent of Scientific Instrument Services, Inc.

4http://www.sisweb.com/sptd/
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CHAPTER

ONE

SOFTWARE INTRODUCTION

Figure 1.1: Thermal Desorption Software

The SIS Thermal Desorption Software (TD Software) controls and operates an SIS short path thermal desorption
system, such as the SIS TD-5 (single sample) or SIS AutoDesorb 2000 (multi-sample) model. The TD Software
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provides a graphical user interface (GUI) from which the operator can configure the TD settings and run parameters,
control the TD operation, and monitor the TD system (e.g. temperatures and pressures). The TD Software resides on
a Windows-based personal computer that is connected to the TD hardware (electronics console) via a serial RS-232
communication cable (or optionally USB via a serial <–> USB converter cable).

The TD system can be operated with the GC in either of two modes: standalone mode (independent of the GC data
system software) and integrated mode (integrated with the GC data system software). Which you use will depend
on whether the TD Software is able to integrate with your particular type of GC data system software. Currently,
the integrated mode only works on most versions of Agilent MassHunter and Agilent (HP) ChemStation GC data
systems. (Check System Requirements and Compatibility (page 11) for specific compatibility requirements or call
SIS.) The standalone mode can work with any GC that the TD system is physically compatible with. The advantage
of the integrated mode is that TD run settings are stored within (linked to) the GC method, and the run operation is
a bit more coordinated–e.g. the TD system will start automatically when a new sample run is invoked from the GC
data system. The integrated mode is especially recommended when running sequences on the AutoDesorb. If using
integrated mode, the TD Software and GC data system software much reside on the same computer to communicate.
In both modes, the TD controller hardware starts the GC run via a contact closure cable connected between the TD
controller and GC, though you could alternately press the Run button on the GC.

Figure 1.2: SIS TD-5 short path thermal system, which supports a single sample.

8 Chapter 1. Software Introduction
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Figure 1.3: SIS AutoDesorb 2000 short path thermal system system, which supports multiple samples.
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Figure 1.4: Communications between TD hardware, TD software, GC data system software, and GC.
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SYSTEM REQUIREMENTS AND
COMPATIBILITY

Overview

Please check system compatibility requirements before installing your system. If unsure, just call us and we will
confirm compatibility and ensure you have the latest TD software. The information below is provided for reference.

Factors to consider include

• GC and/or MS instrument (e.g. Agilent 6890 with 5973).

• GC data system software and version (e.g. Agilent ChemStation E.02.00.493).

• Windows operation system version (e.g. Windows XP or 7).

• SIS TD instrument type (e.g. SIS AutoDesorb or TD-5).

• SIS TD software version (e.g. 1.0, 1.1, 1.2). We will provide the correct version if you don’t have it.

Main questions to answer include

• Is the SIS TD software compatible with your operating system? SIS TD software version 1.2 works with
Windows 2000 through at least Windows 8.0 (including XP and 7). SIS TD software versions 1.0/1.1 are not
compatible with Windows 7 but do support older operating systems (Win95/NT4).

• Is the SIS TD software compatible with your GC data system (e.g. ChemStation/MassHunter)? SIS TD
software version 1.2 integrates with most versions of GC ChemStation (A.xx - B.xx), MS ChemStation (B.xx
- E.xx), and MassHunter (B.xx) as of 2014, though the latest version might no longer support some very old
1990’s era versions. See “ChemStation/MassHunter Compatibility” below for details. The TD software can also
be used in stand-alone mode (not communicating at all with any GC data system), such as has been done on
some Thermo and Varian GC’s (Thermo Xcalibur Usage (page 61)).

• Is the SIS TD physically compatible with mounting on the top of your GC and connecting a remote start
cable? We have long supported 5890 and 6890 GC’s for many instruments. Other Agilent GCs and some non-
Agilent GCs (Thermo and Varian) may be supported too. Some instruments may require adaptation for the GC
mounting plate or contact closure cables. Contact us for details.

• Is your GC data system (e.g. ChemStation or MassHunter) compatible with your GC and operating
system? This question is only pertinent if you haven’t yet installed your GC. Please note that older GC/MS
systems with HPIB communication may not work on newer “E” versions ChemStation or MassHunter. Contact
us or check ChemStation/MassHunter compatibility matrices on the Agilent web site.

– GC ChemStation Compatibility Matrix1

– GC ChemStation Compatibility Matrix (OS)2

– GC/MS ChemStation Compatibility Matrix3

1http://www.chem.agilent.com/Library/Support/Documents/a10674.pdf
2http://www.chem.agilent.com/Library/Support/Documents/FAQ918%20F03013.pdf
3http://www.chem.agilent.com/Library/Support/Documents/F05030.pdf
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GC/MS Instrument Compatibility

We have long supported 5890 and 6890 GC’s for many instruments. Other Agilent GCs and some non-Agilent GCs
(Thermo and Varian) may be supported too. The SIS TD software should work with any Agilent GC that is compatible
with a version of ChemStation or MassHunter that the TD software is compatible with. Contact us for details.

• 5890 - officially supported

• 6890 (A and N) - officially supported. The 6890N (Networked version) requires purchasing an Agilent grey “Y”
cable (G1530-61200) for remote start.

• 7810 (sold with 5975T MSD) - Contact us.

• 7820 (sold with 5975E MSD) - Contact us.

• 7890 (A/A+/B) - has been done but requires mounting plate remachining. Contact us.

• 6850 - mounting plate issue. Contact us.

• Thermo or Varian GC’s - Contact us.

ChemStation/MassHunter Compatibility

SIS TD software version 1.2 integrates with most versions of GC ChemStation (A.xx - B.xx), MS ChemStation (B.xx
- E.xx), and MassHunter (B.xx) as of 2014 If not, we would typically provide a quick software patch to make it work.
Contact us if you have any questions. Below are some details on compatibility testing for reference.

• MS ChemStations and MassHunter

– MassHunter B.07 - SIS TD version 1.2 works with MassHunter B.07 and probably other MassHunter
versions too. Previous SIS TD versions were largely incompatible with MassHunter. The SIS TD software
version 1.2 was tested on B.07.00.1413 (12-May-2013). Note that MassHunter B.07 includes an “F”
version of ChemStation Data Analysis (e.g. MassHunter B.07.00.1413 includes Data Analysis version
F.01.00.1903).

– G1701EA E.xx.xx - SIS TD 1.2 is compatible. 1.2 was tested on G1701EA E.02.00.493 (2008) and
E.02.02.1431 and should work on other E versions. Prior SIS TD versions had a few compatibility issues
(Data Analysis CF_Text error on E.02.02.1431).

– G1701DA D.xx.xx - SIS TD 1.2 and 1.1 are compatible. 1.2 was tested on G1701DA D.03.00.552 and
should work on other D versions. 1.1 was tested more extensively on various G1701DA D.xx.xx versions.
1.1.1 added G1701DA D.02.00sp1 and D.01.02sp1 compatibility. Note that D.01.00sp1 supports a new
hook interface that avoids the SIS TD software needing to customize standard macros.

– G1701CA C.xx.xx - SIS TD 1.2 and 1.1 are compatible. 1.1 and 1.0 were tested more extensively on
various C versions. 1.0 was tested on C.00.00.

– G1701BA B.xx.xx - SIS TD 1.2, 1.1, and 1.0 are compatible. 1.2 was tested on G1701BA B.00.00 and
should work on other B versions. SIS TD software versions 1.0/1.1 were tested more extensively on
various G1701BA B.xx.xx versions of ChemStation.

– G1701AA A.xx.xx - SIS TD 1.1 and 1.0 are compatible. SIS TD software version 1.0.x was tested on
G1701AA A.xx.xx versions of ChemStation including A.01.00. 1.1 works too. 1.2 probably will not work
since it requires Windows version 2000 or above.

– G1034C C.xx.xx (~1996) - SIS TD software version 1.0.x was tested on G1034C C.03.00.00 (on 5890
GC), and the SIS TD software version 1.1.x may work too. SIS TD software version 1.2 probably will not
work since it requires Windows version 2000 or above.

• GC ChemStation

12 System Requirements and Compatibility
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– G2070BA B.xx.xx - SIS TD 1.2 and 1.1 are compatible. SIS TD 1.2 was tested on B.02.01. SIS TD 1.1.1
added compatibility for and was tested on B.01.03.

– G2070AA A.xx.xx - SIS TD 1.2, 1.1, and 1.0 are compatible. 1.2, 1.1, and 1.0 were tested on A.06.03.
1.0 was tested on A.06.01 too.

– Other versions, at least those newer than A.06.03, should work too.

• Other GC data systems may be supported by having the TD software run independently of the GC data system
but synchronize with the GC via contact closure signals, as has been done on some Varian and Thermo GCs.
Contact us for details. (Thermo Xcalibur Usage (page 61))

Operating System Compatibility

• SIS TD software version 1.2 was tested on Windows 2000 through Windows 7 (including XP) and should also
work on Windows 8.

• SIS TD software version 1.1 and 1.0 have some compatibility problems with Windows 7, but they have also
been tested on older operating systems (e.g. Windows NT or 95).

Operating System Compatibility 13



SIS Thermal Desorption Software, Release 1.2.0

14 System Requirements and Compatibility



CHAPTER

TWO

SOFTWARE INSTALLATION

2.1 Overview

This section describes the installation process for the SIS Thermal Desorption (TD) Software.

Figure 2.1: Welcome Page for installation of the Thermal Desorption Software.

2.2 Preparation

Before installing, consider these points:

• See Software Introduction (page 7) for an overview of the software.

15
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• Check your software and hardware versions for compatibility, as described on System Requirements and Com-
patibility (page 11), or just call us.

• The GC data system software (e.g. MassHunter/ChemStation) can be installed before or after installing the TD
software. We suggest installing the GC data system beforehand; otherwise, as a small additional step, you would
need to enable integrated mode after installing the GC data system software. We also recommend testing that
the GC works properly without a TD before installing the TD.

• The TD hardware may be installed and connected to the PC before or after installing the TD software. However,
we do suggest doing a communications test with the TD hardware immediately after installing the software.

• The screenshots in this section might vary slightly from those you see.

2.3 Installation

The first part of the installation process is fairly typical: Run the setup program and follow the instructions on the
screen. If you have an SIS Thermal Desorption Software CD, insert it. Typically, the window in the figure above
will display automatically. You may be prompted to enter your administrator user name and password. (If installation
program does not start automatically, select the Start menu from the Windows Taskbar and in the Run box enter
D:\setup.exe where D is replaced by the drive letter of your CD-ROM drive on your system.)

Note: At any time, you can optionally click the blue Browse Thermal Desorption Documentation link
in the installation program to view the online documentation:

16 Chapter 2. Software Installation



SIS Thermal Desorption Software, Release 1.2.0

Figure 2.2: Online documentation.

Press Next. Select the folder to install the TD Software to (typically c:\Program Files\SIS\TD ):

2.3. Installation 17
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Figure 2.3: Selecting TD program folder.
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Figure 2.4: Ready to install files.

At the end of the installation, you will be prompted to configure the software, start the software, and view the docu-
mentation:

2.3. Installation 19
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Figure 2.5: Installation of files complete.

2.4 Configure TD Software

You should now use the Configure dialog to setup communication between the TD software, TD hardware, and op-
tionally GC data system. The configuration dialog looks like this:

20 Chapter 2. Software Installation
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Figure 2.6: Configuring TD and installing macros.

For now you only need to bother with the parameters on the Communications tab:

• Communications Port: You should specify the serial communications port the TD system is (or will be) con-
nected to. This is typically COM1 but may be some other number.

• GC Data System integration: If you want the SIS TD Software to be integrated with your GC data system
software (integrated mode is supported on Agilent MassHunter and Agilent ChemStation only), you should
select the folder of your GC data system by pressing the ... button (typically c:\GCMS, c:\MSDCHEM,
c:\CHEM32, or c:\HPCHEM). Also select the Integrate with MassHunter or ChemStation
check box to enable the integration and select the MassHunter/ChemStation GC instrument numbers which
will use the TD. If you are not integrating, leave all these fields blank and unchecked.

Technical details on the configuration options are described in Configuration Window (page 36). If unsure about these
options, you can always change them later later via the System > Configure... menu in the SIS TD Software
(or Configure program in the SIS Thermal Desorption program group on the Windows Start menu).

Click Save.

2.4. Configure TD Software 21
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If prompted to Update MassHunter/ChemStation macros? (to enable integration), choose Yes, and it
should say MassHunter/ChemStation macros updated successfully. Further details on the mod-
ifications made to MassHunter/ChemStation to support integration are in ChemStation/MassHunter Modifications
(page 69).

2.5 Reinstalling or Upgrading MassHunter/ChemStation

Warning: If you ever reinstall, upgrade, or move MassHunter/ChemStation after installing the TD software, you may
need to re-integrate to update any macros that may have been overwritten. This can be done by disabling and re-
enabling integration (i.e. from the SIS TD Configuration dialog, disable Integrate, do a Save, enable Integrate, and do
a Save again).

2.6 Uninstallation

You may uninstall the SIS TD software at any time from the Windows Control Panel. Details depend on your version
of Windows but are roughly as follows. Open the Windows Control Panel by clicking the Windows Start button on the
taskbar and then choosing Control Panel or Settings > Control Panel. Then select Programs or Add/Remove Programs
button. On the Install/Uninstall tab, right click SIS TD and select Uninstall or Add/Remove. When prompted to
confirm file deletion, click Yes.

Note: The above deinstallation will remove the TD program and files. It will also attempt to disable Integration by
removing ChemStation/MassHunter Modifications (page 69).

2.7 Starting the Thermal Desorption Software

The TD software is by default set to start automatically following the installation and configuration. The software can
be started again at any later time from the Windows Start Menu > Programs > SIS Thermal Desorption > SIS Thermal
Desorption Program as shown in figure below.

Figure 2.7: Starting the TD software from the Start Menu (Windows 7)
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Figure 2.8: Starting the TD software from the Start Menu (Windows XP)

2.8 Validating the TD Software

Check the following things to ensure the TD software is properly set up:

• Check GC data system integration: If using integrated mode, ensure integration is working: Make sure that
launching the GC data system causes the TD Software to automatically open. Make sure that the title bar of the
TD Software displays the currently selected GC method. If this does not happen, check the integration settings
on Configuration Window (page 36).

• Make sure the TD software communicates with the TD hardware. You should see Cryo-trap connected;
TD connected in the bar at the top of the TD window. The Status Window (page 49) will display the
TD and cryo-trap temperatures. If the TD system does not communicate, you may need to change the serial
communication port settings from the Configuration Window (page 36).

2.8. Validating the TD Software 23
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Figure 2.9: TD software successfully communicating with TD hardware (Cryo-trap and TD detected as being con-
nected and reading temperatures and pressures) and with the GC data system (method name synchronized as seen in
title bars).
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Figure 2.10: TD software not communicating with TD hardware (top bar displaying Analysis halted or taking
a long time Reinitializing controller and giving Could not communicate with controller
error message).

2.8. Validating the TD Software 25
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THREE

SOFTWARE OPERATION

Figure 3.1: SIS Thermal Desorption (TD) Software window.
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3.1 Overview

This section summarizes the SIS Thermal Desorption (TD) Software and its use in configuring, running, and monitor-
ing the TD unit. See Software Introduction (page 7) for a background on the TD Software. More detail is provided
later in GUI Windows (page 35).

3.2 Getting Started

Before you begin using the TD system, make sure that it has been properly installed. This pertains not only to the
Desorption Unit, Electronics Console and Cryo-Trap, but also to the TD Software. Installation by a technician trained
by SIS is recommended, and certain warranty provisions may be void unless the installation is performed by certified
personnel. Installation by an authorized agent of SIS is always accompanied by initial training in the use of the system
using customer samples when possible. This is the best way to be sure that your system is correctly installed.

At a minimum, verify that carrier gas, compressed air, electrical power, and if applicable, cryogenic fluid have been
correctly connected and supplies are adequate. Verify that the Desorption Unit is in place over the GC inlet and that
the centering septum nut is present.

It is also recommended to READ THIS MANUAL THOROUGHLY before using the system.

3.3 System Startup

Turn on the power to the Electronics Console and start the TD software. If the TD Software is running in integrated
mode (integrated with your GC data system), the TD Software will open automatically when the GC data system is
opened. If not, start the TD Software manually as shown in Software Installation (page 15). When the TD software
is started, it will attempt to communicate with the Electronics Console. Any error messages will be displayed at this
time. See Validating the TD Software (page 23) to ensure the software is properly working.

Once the system has started and initialized, a method can be created, or samples may be run using a previously stored
method.

3.4 Using TD Methods

Parameter settings for one or more TD runs are contained in a TD method, which can be saved as a file with extension
.mth. You can have multiple methods, which can be loaded, saved, and edited as needed using the TD Software.

Furthermore, if the TD Software is used in integrated mode, the TD method will be saved (and linked to) the GC
method in your GC data system so that appropriate TD parameters will be loaded automatically when a GC method is
loaded in your GC data system.

Creating a TD method is a matter of modifying an existing one to suit the current analysis. A default method is loaded
when the TD Software is started in standalone mode or if a GC method without thermal desorption settings is loaded
in integrated mode.

3.4.1 Method Edit View

The TD method settings can be edited from the Method window, which is accessible from the View > Method

Edit View menu item or the button on the toolbar.
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Figure 3.2: TD Method window

The main parameters for the TD are the Purge, Inject, and Desorb times and the temperature settings for the desorption
heater and cryo-trap. Other parameters include the GC start time and Cryo-Trap heat delay and duration. These
parameters are described in detail in Method Window (page 46).

3.5 Saving settings

When modifying an TD method, it is important to remember to save the changed settings by selecting Method >
Save Method or Method > Save Method As from the menu bar or (in integrated mode) by saving the entire
method from the GC data system. If the setting changes are not saved, the prior settings will be restored the next time
the method is loaded. As a reminder, the text METHOD NOT SAVED appears in the lower right-hand corner of the
TD Software, as well as an asterisk (*) in the title bar, whenever a setting change is made but not yet saved. Setting
changes can be made at any time, even in the middle of a run. Although not recommended for normal operation, this
flexibility can assist in method development. Any changes that are made during a run are recorded in the Sample Log
Book (page 51); however, changes must be saved if successive runs in a sequence are to use the new settings.

Importing settings In integrated mode, it can be useful to import TD settings from one GC method into another. This
is made possible by the Method > Import Method... menu item.

3.6 Running a Single Sample

Once GC and TD methods have been defined, a sample may be run from the data system.
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In standalone mode, get the GC into a ready state and then in the TD Software select the Run > Run Sample...

menu item or click the button, and then click Start Run.

In integrated mode using MassHunter/ChemStation, the following procedure is used. From the GC data system
Instrument Control or Run Control window, select Method > Run (Method) to activate the Start
Run window. Edit sample information and click the Run Method button in the Start Run window. Details will
vary depending on the version of your GC data system. The entire data system method, including TD settings, will be
executed when the GC becomes ready.

Figure 3.3: Method from older ChemStation.

30 Chapter 3. Software Operation



SIS Thermal Desorption Software, Release 1.2.0

Figure 3.4: Run Method from MassHunter

Run monitoring view: It can be convenient to monitor the run using the Run Monitoring View, accessible from the

View > Run Monitoring View menu (or button). This shows the Status Window (page 49), temperature
profiles, and Sample Log Book (page 51).

Terminating a run: If for any reason the sample must be aborted or stopped during the run, do so by selecting the Run

> Reset Controller... menu item of clicking the button on the toolbar. The TD Ssoftware contains
error handling protocols that will assure that the GC oven temperature program is run if there is an error following
the desorption blocks having been closed. Stopping the GC run from ChemStation may result in desorbed analytes
remaining on the column into the next run.

3.7 Running a Sequence of Samples (AutoDesorb)

The AutoDesorb supports running up to 12 samples unattended.
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In standalone mode, you can use the Sequence Window (page 55) in the TD software. (example: Thermo Xcalibur
Usage (page 61)).

When integrated with MassHunter/ChemStation, the sequence table in the GC data system is used to control the entire
sequence. Using MassHunter or ChemStation, perform the following steps (details may vary slightly depending on
the version of your GC data system):

1. From the top MassHunter of ChemStation window, select Sequence > Edit (Sequence) or Sequence
> Edit Sample Log Table from the menu bar.

2. Enter all the sample information as you would for liquid samples, including vial numbers (carousel positions),
data file name, method and comments.

3. Click OK and return to the Top window.

4. Select Sequence > Save (Sequence) from the menu bar, and name the sequence file.

5. Select Sequence > Run (Sequence) from the menu bar.

The sequence will then proceed as normal.

Figure 3.5: Running a sequence from ChemStation.

Caution: You may notice that the TD Software provides a Sequence Window (page 55) of its own (Run > Sequence
menu). This is not used when operated in integrated mode. This sequence table is provided for situations where
integrated mode cannot be used (e.g. non-Agilent GC data systems).

NOTE: Samples need not be run in numerical order and may even be run multiple times or with different methods.
Sequences may have as many lines as necessary and are not restricted to the number of tube positions on the carousel.
Each Vial Number entry, however, must correspond to a position on the carousel, and values must therefore be between
1 and 12. Tubes may be loaded and unloaded during the sequence whenever the door on the desorption unit is unlocked.

If the sample or sequence must be stopped prematurely, do so by clicking the button on the TD software.
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Depending on the desorption system state at the time the controller is reset, the choice may be given to retry or skip
the sample. Check the Sample Log Book (page 51) to see whether the tube may be re-analyzed or if the sample has
been compromised by going through an incomplete desorption cycle. If the entire sequence is to be aborted, that
should be done through the data system before responding to the Skip/Retry request from the TD Software.
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CHAPTER

FOUR

GUI WINDOWS

This is a description of each window and field in the GUI in more detail. See Software Operation (page 27) for a
summary of the GUI.

Figure 4.1: SIS Thermal Desorption Software main window.
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4.1 Configuration Window

This dialog box is for configuring the thermal desorption system, such as communication ports, system limits, and
debugging options. Changes are global: settings here affect all methods.

Figure 4.2: Communication settings.
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Figure 4.3: System limits.
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Figure 4.4: Advanced configuration settings.

4.1.1 Communications Parameters Tab

This tab configures the communication between the TD software, TD hardware, and GC data system software.

Communications Port

This is the name of your the serial communications port on your PC to which the thermal desorption controller is
connected to. Typically this is COM1 or COM2 but may be higher for USB ports. The port number may be labed on
the back of your computer. You need only try ports that are marked with (port found), which indicates that the
port was detected on the system (but says nothing about whether the TD is plugged into or connected to that port).
A list of valid communications ports can also be found in the Ports section of the Windows Device Manager in the
Windows System Control Panel (when can be opened by clicking the Device Manager button). If not sure, try
selecting COM1, COM2, and maybe a higher port number and see if the software communicates with the controller

by pressing the button or the Test button to try to reinitialize the controller using the port number selected.

[[Note: The SIMULATOR option is intended strictly for debugging purposes and should not normally be selected. It
will simulate the TD controller hardware in software, thereby allowing the software to be operated without any actual
TD controller hardware actually connected to your PC.]]
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Figure 4.5: Serial ports on TD-5 (left) and PC (right). Connect serial cable (middle) between them. Your ports and
cables may looks slightly different.
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Figure 4.6: Optional serial-to-USB converter cable (top) can connect TD controller into USB port of PC and RS232
port of TD controller (bottom).
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Figure 4.7: Optional serial-to-USB converter cable can be extended if needed with a serial serial cable.

The Windows System Control Panel Device Manager Ports can be helpful for displaying and viewing the serial
(RS232) communications ports available on your system. This can be conveniently accessed from the Device
Manager button on the SIS TD software Configure window or from the Windows Start menu as shown below.
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Figure 4.8: Windows System Control Panel Device Manager Ports (Windows 7)
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Figure 4.9: Windows System Control Panel Device Manager Ports (Windows 2000)

MassHunter or ChemStation Program Path

The is the program folder for your Agilent MassHunter or Agilent ChemStation data system. You can leave this field
blank if you are not integrating the SIS Thermal Desorption Software with your GC data system software (i.e. stan-
dalone mode). It is typically c:\GCMS (for MassHunter), c:\MSDCHEM (for newer MS ChemStations), c:\CHEM32
(for newer GC ChemStations), or c:\HPCHEM (for older ChemStations). Note: this folder would typically contain a
subfolder named msexe (for MS ChemStation and MassHunter) or core (for GC ChemStation).

The Thermal Desorption software needs to know this folder in order to install custom macros into your GC data
system to allow the SIS Thermal Desorption Software and GC data system to integrate, as described in ChemSta-
tion/MassHunter Modifications (page 69).

Integrate with MassHunter or ChemStation

Check this box if you want to integrate the SIS Thermal Desorption Software with your GC data system (integrated
mode) by installing macros in the latter. Uncheck this box to disable integration.

Macros will be installed or uninstalled when you click Save.

Connect desorption software to these GC instruments

MassHunter and ChemStation can control up to four GC or other instruments at a time. Select which instrument
numbers on which thermal desorption should be enabled. If checked, the SIS Thermal Desorption Software will
automatically launch when you launch that instrument number and respond to events like loading/saving methods or
starting a run from your GC data system.
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4.1.2 Limits Parameters Tab

This tab controls various limits on things like temperatures and times, typically for safety reasons. You should not
normally change these.

Cryo-Trap Max Heating Temp (C)

The maximum cryo-trap heating temperature that can be specified in the method. The actual cryo-trap temperature
may be allowed to overshoot above this value during a run but never outside the hard limits imposed by the controller
itself. The default is 300 C and maximum is 400 C.

Cryo-Trap Max Heating Time (min)

The maximum time duration of cryo-trap heating that can be specified in the method. This may help prevent damage
to the cryo-trap or column. The default is 90 min.

Cryo-Trap Max Cooling Time (min)

The maximum time duration of cryo-trap cooling that can be specified in the method. This may prevent unnecessary
draining of the cooling gas. The default is 60 min.

TD Max Purge Time (min)

The maximum time duration of purging that can be specified in the method. This may prevent unnecessary draining
of the carrier gas. The default is 60 min.

TD Max Inject Time (min)

The maximum time duration of injection that can be specified in the method. This may prevent unnecessary draining
of the carrier gas. The default is 15 min.

TD Min Pressure to Run (psi)

The minimum pressure that must be observed at the end of the inject step in order for the run to proceed. The run will
be skipped if this pressure is not met. Failure to reach pressure can indicate a leak (e.g. connections on the sample
tube not tight). The default is 1.0 psi (and maximum is 75 psi), but you may need to reduce this in some situations.

TD Max Pressure (psi)

The maximum carrier gas pressure allowed to be observed inside the thermal desorption system. Exceeding this can
indicate a plug in a line. The system will be shutdown for safety if this value is exceeded. The default is 60 psi and
maximum is 75 psi.

TD GC Gas Divert Time (sec)

The time duration after the start of the injection in which to turn on the GC divert value. The GC divert valve cuts
of the carrier gas to the GC and sends all carrier gas through the thermal desorption tower. The default is 20 sec and
maximum is 100 sec. Note: if the inject duration in your method is shorter than the GC divert time, then the carrier
gas will not divert. This is by design and can be useful in some situations.

TD Tube Cool Time (min)

This is the time duration that tube will be cooled (with purge gas flowing through it) after the desorption. This time is
intended as a safety measure to prevent the operator from getting burned by touching a hot sample tube. The default
is 5.0 min.

TD Max Temp (C)

This is the maximum desorption block temperature that can be specified in the method. The actual temperature may
be allowed to overshoot above this during a run but never outside the hard limits imposed by the controller itself.
This may help prevent damage to the desorption blocks/PRT or other overheating problems. The default is 400 C and
maximum is 450 C.

TD Max Heat Time (min)
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This is the maximum time duration of desorption block heating that can be specified in the method. This may help
prevent damage to the desorption blocks/PRT or other overheating problems. The default is 30 min.

TD Max Ramp Rate (C/min)

This is the maximum ramp rate than can be specified in the method. The default is 100 C/min, which is approximately
the maximum ramp rate that is physically possible. You shouldn’t need to change this.

Restore Defaults

This button restores the limits to default settings.

4.1.3 Advanced Parameters Tab

This tab defines various other settings.

Debug Logging

If checked, this enables logging of communications messages between the PC, GC data system, and the thermal
desorption controller. This is intended for debugging in the case of a problem. It may be enabled by default on new
installations. You can click the View button to view this log in real-time (and optionally then click Log Folder to
access the folder where this log file (debug.log) is stored, such as to e-mail this file to SIS for analysis).

Advanced configuration commands

Here is specified a semi-colon-delimited list of configuration commands to execute each time the thermal desorption
controller is reset (which is included every time a new run is started). This is an advanced option, generally only used
when directed by SIS to tune a system (e.g. modify temperature control characteristics). By default, this field is blank.
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4.2 Method Window

Figure 4.10: Method Window

The thermal desorption Method window (figure above) enables the user to view and edit parameters on the currently
open TD method. The currently open method can be select from the Method > Open Method... or Method
> Save Method... menu items or from the GC data system (e.g. ChemStation/MassHunter integrated mode).
The method is typically edited before a run but can also be interactively edited during a run (can be useful for method
development). The method times and temperatures are displayed graphically on the right side of the window, and time
bars and temperature traces will be plotted here during the run.

This window is accessed by selecting the View > Method Edit View menu item or clicking the .

4.2.1 Description of Each Parameter

TD Enable and Cryo-Trap Enable

The thermal desorber (TD) and the cryo-trap can be independently enabled or disabled in the method by check-
ing/unchecking the Enable check boxes in the method. Therefore, the combinations are possible:

• TD enabled and cryo-trapping enabled (TD with cryo-trapping)

• TD enabled and cryo-trapping disabled (TD without cryo-trapping)

• Cryo-trapping enabled and TD disabled (cryo-trap run)
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• Cryo-trapping disabled and TD disabled (GC only run)

An example of a method that would use TD without the cryo-trap is the thermal extraction of high-boiling components
from a soil sample (e.g. PCB’s or Polynuclear Aromatic Hydrocarbons). In this case, materials that would be focused
on the column cryogenically might only interfere with the analysis. Likewise, the cryo-trap may be used independently
of the TD for focusing static headspace injections.

Purge Duration (min)

This is the duration of time in which gas is purged across the desorption tube before the needle is lowered into the
GC inlet. This purge allows for a volume of carrier gas to remove oxygen, excess water, or other unwanted volatile
materials that may be resident in the tube. The default setting for the purge gas time is one minute. Note that the
retention of some analytes may be affected by this purge, and the use of a more appropriate trapping resin may be
indicated if sample is lost due to this small volume. Purge gas flow is regulated by a mass flow controller mounted on
the front or top of the desorption unit. The flow should be adjusted to provide adequate carrier to sustain the total flow
for the highest split to be used. The setting is best made by adjusting the flow controller during the Inject period, after
the carrier has been diverted (see below).

Inject Duration (min)

This is the duration in time of the injection stage. The inject stage allows for pressure equilibration. The inject stage
begins when the needle is lowered into the GC inlet and ends when desorption heating begins. A drop in inlet pressure
is normal as the septum is punctured; however, re-pressurization should follow rapidly as the desorption purge flow
and normal GC carrier are both directed into the inlet. The dual flow lasts for a preset time after which the carrier
gas regulated by the GC’s pressure control feature is diverted to pass through the desorption unit. The default value
is 20 seconds (0.3 minutes) for the dual flow period but is changeable from GC Gas Divert Time (sec) setting in the
System > Configure... > Limits menu. In this way, the pressure and flow control are handled by the
GC for maximum consistency. Although an inject time setting of one minute is supplied in the default method, it
should be set in conjunction with the Purge Gas flow to allow the injection port pressure to equilibrate and the proper
split flow to be reached before the time expires. At least once for each method, it is advisable to check the split flow
after the carrier gas has diverted, and adjust the time if necessary (see below figure). At the end of the Inject stage, a
pressure reading from the desorption unit is compared to the Minimum Pressure to Run setpoint in System
> Configure... > Limits menu selection. If the minimum pressure is not met a leak is assumed (for the
AutoDesorb, the tube is returned to the carousel, and the sequence advanced to the next sample).

WARNING: SPLITLESS INJECTION IS NOT RECOMMENDED. The low flow rate associated with most splitless
injections does not provide an efficient transfer of material from the desorption tube to the column. Most chro-
matographs will yield inconsistent results with splitless injection due to difficulty regulating the inlet flow through the
desorption unit in this mode.

Figure 4.11: Setting the Inject time parameter.
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Desorption Total Time (min)

When the Inject stage ends, the heater blocks close around the desorption tube, heat up, and remain closed for the time
duration specified here. The total Desorb duration cannot be edited directly but rather is calculated automatically from
the temperature ramp rates and hold times specified in the Temperature Programs. The value supplied in the default
method is five minutes.

Desorption Temperature Programs (Ramp/Temp/Hold)

This specifies the temperatures, times, and ramp rates for the desorption process (sample heating). For isothermal
desorption (recommended for most adsorbent trap methods) the only entries necessary are the initial temperature (C)
and desorption duration (min). For ramped desorption (recommended for Direct Thermal Extraction) one or more
segments of the temperature program are selected for use by checking the box next to the segment label (Ramp 1,
Ramp 2, and Ramp 3). When selected, heating rate (C/min), target temperature (C) and hold time (min) for each
segment may be entered. The maximum controlled heating rate is 100 C/min. A heating rate value of 0C will result in
the ballistic heating of the sample. Total desorption time is calculated automatically.

Cryo Cool Temp (C)

This is the set-point temperature for the cryo-trap during the cryo-trap cooling stage. The cryo-trap is in the cooling
stage throughout the purge, inject, desorb and cryo heat delay stages of the thermal desorption. cryo-trap cooling
temperature may be set between roughly ambient temperature and -70 C for liquid CO2 use or between ambient and
-180 C for liquid nitrogen. Cooling temperature should be set below the freezing point of the most volatile compound
being analyzed. When using liquid CO2, trapping efficiency may be enhanced by using thicker film guard columns.
When using liquid nitrogen, trapping temperatures often go below the glass transition point of the polysiloxane bonded
phases (~ -60 to -70 C). Therefore the use of a bonded phase offers no advantage in terms of trapping efficiency and
may actually be detrimental to the column due to the rapid temperature changes. Deactivated fused silica guard
columns are recommended for use with liquid nitrogen. For either liquid nitrogen or liquid CO2, the use of a wide
bore capillary guard column will increase the trapping capacity and minimize the chance of an ice plug forming in the
trap.

Cryo Heat Temp (C)

This is the set-point temperature for the cryo-trap during the cryo-trap heating stage. The cryo-trap goes into the
heating stage immediately after the Cryo Heat Delay (see below) on the thermal desorption. The cryo-trap heating
temperature should be set slightly higher than the GC inlet. Keeping each successive stage of the chromatographic
system hotter than the last helps to keep the system clean and prevent carryover.

Cryo Heat Delay (min)

This is the duration in time from the end of the desorption heating to the start of the cryo-trap heating. This delay
provides a short equilibration period after the desorption needle is removed from the inlet. During this time, the cryo-
trap is held in cooling mode to prevent pressure fluctuations from affecting chromatography. The default value for
the cryo heat delay is 30 seconds. At the end of the delay, the cryo-trap is ballistically heated to release the focused
analytes instantaneously, much like a liquid injection.

Cryo Heat Duration (min)

This is the duration in time that the cryo-trap is heated. Most volatile materials should be released in the first few
seconds of heating. Keeping the cryo-trap heater on for long durations may shorten its life. The default setting of five
minutes is recommended for most analyses.

GC Start Time (min)

The is the time at which the TD system sends a signal to the GC to start the GC run. The time specified here is
relative to the beginning of the Purge stage. The GC may be started at any time after the start of the Purge. Normally
the GC Start time is set to coincide with the start of the cryo-trap heating by using the sum of the Purge, Inject,
Desorb, and Heat Delay times. This provides chromatographic results that most closely match those obtained by
liquid injection. Starting the GC early may be useful in method development (particularly when choosing a cryo-trap
cooling temperature) since compounds breaking through a cryo-trap that is too warm may go unnoticed unless the data
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system has been started. Early GC start times may also be used to take advantage of functions such as inlet pressure
programming that are controlled from the GC time base.

4.2.2 General Notes

Changing and saving method parameters: When modifying a thermal desorption method, it is important to re-
member to save the changed settings by selecting File > Save Method from the menu or by saving the entire
method from the data system (e.g. ChemStation integration). If the setting changes are not saved, the prior settings
will be restored the next time the method is loaded. As a reminder, the text METHOD NOT SAVED appears in the
lower right-hand corner of the TD software window, and an asterisk (*) displays in the title bar, whenever a method
change is made but not yet saved. Method changes can be made at any time, even in the middle of a run. Although
not recommended for normal operation, this flexibility can assist in method development. Any changes that are made
during a run are recorded in the log book; however, changes must be saved else the original method settings will be
reverted on the next run.

Method Import: A TD method can be imported from another method by selecting File > Import Method
form the menu. Importing a method copies the contents of the imported method over the currently open method. The
ability to import methods can reduce the for data entry. For example, you might want to import thermal desorption
method settings from another data system method into the current data system method. To preserve the changes to the
current method, you must Save Method.

4.3 Status Window

Figure 4.12: Status window

The Status window displays the current status of the thermal desorption system (e.g. current temperature and pressure
readings). The window also includes an animated graphical representation of the thermal desorption system on the
right.
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This window is displayed by selecting the Run Monitoring View (View > Run Monitoring View from the

menu or the button).

4.3.1 Description of Each Field

Tube (View)

(AutoDesorb only) The tube number (1..12) of the current sample loaded by the AutoDesorb autosampler. This field
is not displayed on the TD-5.

Sample File

The name of the currently running sample. This identifier is taken either from “sample name” field in the Run Window
(page 54) or (if integrated with the GC data system, e.g. ChemStation/MassHunter) from the name of the GC data
system data file for the current GC run.

TD Status

The current state of the thermal desorption.

Cryo Status

The current state of the cryo trap.

Cryo Gas Type (CO2/LN2)

Indicates whether CO2 or LN2 cooling gas is connected to the cryo-trap. This is detected by the cryo-trap plug on the
back of the TD controller.

GC Status

The current state of GC. The GC state is inferred from the GC ready signal and the state of the TD software.

Time (min)

The run time. This is measured from the start of the Purge stage.

TD Temp (C)

The current desorption blocks temperature (feedback reading).

Cryo Temp (C)

The current cryo trap temperature (feedback reading).

Purge (ON/OFF)

Indicates whether the purge gas is on or off.

Divert (ON/OFF)

Indicates whether the GC divert valve is on or off. The divert valve diverts carrier gas from the GC and entirely through
the thermal desorption system.

Pressure (psi)

The carrier gas pressure through the desorption system.

Graphical Window
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Figure 4.13: Graphical display of TD status.

The graphical display will show a picture of the TD operation. The above picture shows the typical states for an
AutoDesorb 2000 (the TD-5 is similar but without loading tubes from the carousel table).

The purge and carrier gas will display as green in the upper left. Cryo-trap and desorb block heating and cooling will
display are red and blue respectively. The tube arm will move and blocks will close and open.

4.4 Sample Log Book

Figure 4.14: Log Book Window

The Thermal Desorption Software has extensive error and status logging functions. The Sample Log Book (above
figure) keeps track of all runs, errors and method changes that occur during a run or sequence. It is an excellent tool to
use for diagnosing problems, verifying that sequences have run completely, and tracking method changes. The Sample

4.4. Sample Log Book 51



SIS Thermal Desorption Software, Release 1.2.0

Log Book can be accessed by clicking selecting the View > Run Monitoring View menu item or clicking the

button on the toolbar.

An entry in the Log Book is created every time the data system begins a run. The initial entry consists of one line of
text and contains the Tube number, Time, Date, Data file name, Method name and the names of active instruments in
the method being used (e.g., cryo-trap or TD). Most often, only one more entry is made for each sample when the data
acquisition is complete, and it contains the time and a message confirming the successful completion of the sample.
Entries for different samples are separated by a solid line. When an error or a method change occurs, the event is
logged with the time, the error or change, and sometimes extra information about the sample.

Sample Log Book data is stored in a file named default.log, typically in the
C:\ProgramData\SIS\TD\logs directory (or C:\Documents and Settings\All
Users*\SIS\TD\logs on old versions of Windows). The Sample Log Book may be opened in Notepad
by clicking the Edit... button on the Sample Log Book. The Sample Log Book may be archived (opened in
Notepad and saved with a different name) or cleared via the Clear... button.

4.5 Menu Bar and Toolbar

Figure 4.15: Menu bar and toolbar.

The functions on the menu bar and tool bar are described here.

4.5.1 Method > Open Method...

Opens an existing TD method. The TD method is saved in a text file with the file name extension ”.mth”.

If the TD software is integrated with a GC data system (e.g. ChemStation/MassHunter), you can also load GC method
from the data system, and the TD software will automatically open the corresponding TD method.

4.5.2 Method > Save Method

Saves the current TD method.

If the TD software is integrated with a GC data system (e.g. ChemStation/MassHunter), you can save the GC method
from the GC data system, and the TD software will save the corresponding TD method with it as well.

4.5.3 Method > Save Method As...

Saves the current TD method to a new name.

If the TD software is integrated with a GC data system (e.g. ChemStation/MassHunter), you would typically use the
Method > Save Method As instead to save the method with the current GC data system method.
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4.5.4 Method > Import Method...

Imports the contents of another TD method to the currently open method. See Method Window (page 46) for details.

4.5.5 Method > Print Method...

Prints the contents of the current TD method to the printer.

4.5.6 Method > Exit...

Closes the TD software. This will terminate any current TD run (use with caution).

4.5.7 Run > Reset Controller...

Resets the TD controller. Use this to terminate a run or reinitialize the controller.

4.5.8 Run > Run Sample(s)...

Opens the Run Window (page 54) for starting one or more TD runs (or the Sequence Window (page 55) if it contains
multiple samples) independent of the GC data system. If the TD software is integrated with a GC data system (e.g.
ChemStation/MassHunter), you would typically instead initiate the run from your GC data system, and your GC data
system will then signal the TD software to start a run.

4.5.9 System > Configure...

Opens the Configuration Window (page 36) for configuring system parameters (e.g. communications ports, system
limits, and debugging options.

4.5.10 System > Manual Control (Troubleshooting)...

Opens the Manual Control Window (page 57), which allows temperatures and valves to be manually turned on an off
(useful for debugging). Presently this only works with the TD-5.

4.5.11 View > Method Edit View...

Shows the Method Window (page 46) for viewing/editing method parameters or monitoring time and temperature
tracing during a run.

4.5.12 View > Run Monitoring View...

Shows various windows useful for monitoring the run including the Sample Log Book (page 51), Status Window
(page 49), and Method Window (page 46).

4.5.13 Help > Help...

Opens the TD help and documentation.
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4.5.14 Help > Help on Menu/Toolbar...

Displays help on menu and toolbar.

4.5.15 Toolbar

The buttons on the toolbar are shortcuts to menu items. From left-to-right, the buttons above are as follows: View >
Method Edit View, View > Run Monitoring View, Run > Reset Controller..., Run > Run
Sample(s)..., and Help > Help.... The text in the center of the toolbar is a status bar displaying the current
state of the system (e.g. running). The status bar is green when a sample is running.

4.6 Run Window

Figure 4.16: Run Window

This window enables you to begin one or more thermal desorption runs from the thermal desorption software.

NOTE: You need not use this dialog box if your GC data system is integrated with the thermal desorption software
(e.g. ChemStation/MassHunter) because the GC data system will automatically signal the thermal desorption to start
at the start of the GC data system run.

4.6.1 Description of Each Parameter

Sample Name
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This is any arbitrary sample identifier you provide. It will be recorded in the Sample Log Book (page 51). (When
the GC data system is integrated with thermal desorption system–e.g. ChemStation/MassHunter–the GC data system
provides this information.)

Tube Number

The number of the sample tube to run. This is only used in the AutoDesorb (not the TD5). With the TD5, this field
is disabled and by default set to 1. (When the GC data system is integrated with thermal desorption system–e.g.
ChemStation/MassHunter–the GC data system provides this information.)

Start Thermal Desorption Run

Starts the thermal desorption run. Load the tube and input the above parameters before clicking this button.

View Sequence Table

This opens the Sequence Window (page 55) for running any number of samples in sequence. This is typically only
useful for multi-sample thermal desorption systems such as the AutoDesorb (not the TD-5).

4.7 Sequence Window

Figure 4.17: Sequence Window
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This window enables you to set up and run a sequence of samples from the thermal desorption software. This window
is largely intended only for multi-sample versions of the thermal desorption system (e.g. the AutoDesorb, not the
TD5).

NOTE: You need not use this dialog box if your GC data system is integrated with the thermal desorption software
(e.g. ChemStation/MassHunter) because the GC data system will initiate runs instead.

The sequence table lists all the samples to be run. Each sample can use an individual tube and thermal desorption
method.

4.7.1 Description of Each Parameter

Tube #

The number of the sample tube to run (AutoDesorb only).

TD Method

The name of the thermal desorption method file to use (*.mth). Click the folder button on the right to select a method
file using the file open dialog box.

Add Sample

Adds a new sample to the sequence table. To use this, enter the samples parameters and then click this button.

Delete Sample

Deletes the currently selected row in the sequence table. To use this, select the row in the sequence table and then
press this button.

Modify Sample

Modifies the currently selected row in the sequence table. To use this, select the row in the sequence table, edit the
parameters, and then press this button.

Up / Down

Moves the currently selected row to the previous/next position in the sequence table. To use this, select the row in the
sequence table, and then press this button.

Process Queue (ON/OFF)

Enables or disables processing of the samples in the sequence table. When enabled, the system will run the first sample
in the sequence table. When a sample run is complete, it is removed from the queue and the sequence advances to the
next sample. This is a toggle button. When pressed down, samples in the sequence table will be processed. When not
pressed down, the sequence table will be paused (but the current sample will continue running unless you press Reset).
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4.8 Manual Control Window

Figure 4.18: Manual control window.

This window allows you to manually operate the TD system movement, valves, and temperatures. It is useful for
debugging purposes.

Presently, the window shown above can only be used with the TD-5, not AutoDesorb. If you are using an AutoDesorb,
the Hardware Tester Window (page 59) will display instead.

4.8.1 Description of Each Parameter

Load State:: Sets the position of the TD arm mechanism.

• UNLOAD: unloaded tube position

• LOAD: loaded tube position (same as UNLOAD)

• INJECT: inject tube into GC inlet

• CLOSE BLOCKS: close blocks around injected tube.

Purge Gas:: Check to enable the TD purge gas.

GC Gas Divert:: Check to divert the GC gas through the TD system rather than through the GC.

Cryo Cool:: Check to enable cryo-trap cooling. The set-point temperature (C) is defined in the box below.

Cryo Heat:: Check to enable cryo-trap heating. The set-point temperature (C) is defined in the box below.

Desorb Heat:: Check to enable desorption block heating. The set-point temperature (C) is defined in the box below.

GC Start Signal: Causes the TD controller to send a start contact closure signal to the GC through the cable that
connects the TD controller to the GC.

Beep: Causes the TD controller to beep.
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Reset: Resets the TD controller. This is the same as pressing the button.

4.9 Advanced Diagnostics Windows

Some advanced functions are available for diagnostics purposes. These are not usually displayed in the software.
Contact SIS if you need to access them.

WARNING: Some of these windows bypass usual safety logic. Use caution when using these functions to avoid
damage to the system or harm to the operator.

4.9.1 Command Tester Window

Figure 4.19: Command Tester window.

The Command Tester window allows you to send and receive communication commands to/from the TD electronics
controller.

Enter a command in the first text box, press send, and the response is displayed in the second text box. Any system
status commands (TDSTATUS) polled by the TD software are also displayed below it and decoded.

Various controls at the bottom of the window are provided for convenience for forming commands, including viewing
and changing states.

Hint: The controller (CTRL) must be in state “3: Run” in order to do any heating, cooling, or arm movements.

The Log button displays the debug log, which records communications commands. This is the same as Advanced
Parameters Tab (page 45).

If using the TD-5, you may want to instead use the Manual Control Window (page 57), which is intended more for an
end user, not as low level, and perhaps a little safer and more restricted.
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4.9.2 Hardware Tester Window

Figure 4.20: Hardware Tester window.

The Hardware Tester window allows you to directly view the digital input (DIN) and analog input (UIN) readings and
set the digital output (O) on the microprocessor board in the TD controller. It is mainly intended for debugging by a
technician familiar with what these controls do. The outputs should be used with much caution because they bypasses
usual safety logic (e.g. prohibit extending the AutoDesorb arm when injected or the door is open). Some outputs
related to the heating/cooling are disabled for safety and because the TD logic regulates these automatically according
to the temperature set-points.

You may want to instead use the Manual Control Window (page 57), which are not as low level as this window, or the
Command Tester Window (page 58).
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FIVE

THERMO XCALIBUR USAGE

Figure 5.1: SIS TD software and Thermo Xcalibur software.

5.1 Overview

This document provides information specific to using the SIS AutoDesorb with the Thermo Finnigan Trace GC and
Xcalibur. For general and more detailed information on the AutoDesorb, refer to the AutoDesorb manuals.

Xcalibur requires using standalone mode (not integrated). You can use the Method Window (page 46), Run Window
(page 54), and Sequence Window (page 55) from the TD software to setup methods, runs, and sequences.
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5.2 Installation

Your AutoDesorb can be installed as follows:

• 1. Ensure that GC and software (typically Xcalibur) is properly configured and working. Refer to the GC and
Xcalibur documentation for details.

• 2. Install the SIS TD hardware. Refer to the SIS AutoDesorb Installation Manual for details as well as the GC
specific notes below.

• 3. Install the SIS TD software. Refer to the SIS Thermal Desorption Software Manual for details.

5.3 Flow Control - Trace GC

For proper control of carrier gas flow for thermal desorption, your GC should have an appropriate digital pressure
flow control module installed. In August 2005 we were informed Thermo upgraded their TraceGC flow controller and
firmware to give more backpressure control than previous models, and we recommend the newer model. We tested
# 19050235 Kit DPFC2001 Upgrade Trace kit which includes the 250 kPa Electronic Flow Controller and the latest
EPROM version 2.08 (Thermo part# 30307019) for the mainboard behind the GC.

The flow controller has two adjustments that need to be made. One adjustment is the S1 micro-switches on the DFPC
card (1 and 2 OFF and 3 and 4 ON) and the other adjustment is to a Pneumatic Switch with a block that needs to be
oriented in a certain position.

Regarding the EPROM placement on the board, the board lays flat inside the grey plastic “breadbox” and can be
removed by unplugging cables and removing 4 screws from the underside of the plastic “breadbox”. There is an index
on one side of the EPROM and on one side of the mainboard that need to match up.

Carrier gas line- cut and both ends connected into SIS GC Gas Valve Assembly Split Vent line- cut and one end
connected into a Tee and the other end going to the injector Septum purge line- cut and one blocked off near the
injector but the other open end goes into a Tee

Thermo has another kit for 3rd party P&T systems (119245-0001, “Purge-and-trap interface for TRACE GC capil-
lary injector”), but this kit is not required. THE ORIGINAL MANUAL #31709382 HAS BEEN REVISED FOR
THIS 119245-001 KIT. THE PNEUMATIC TUBING SCHEMATIC IS DIFFERENT BETWEEN THE ORIGINAL
VERSION OF THIS MANUAL WE RECEIVED. THE MICRO-SWITCHES AND PNEUMATIC SWITCH CON-
FIGURATIONS ARE THE SAME BETWEEN BOTH VERSIONS OF THE MANUAL.

5.4 Handshaking signals between the Trace GC and AutoDesorb

A handshaking cable (provided by SIS) must be connected between the “Generic Handshake” connector on the back
of the GC and the “Remote Start” connector on the back of the AutoDesorb controller.

The handshake signals must also be properly configured on the Trace GC keypad.

On the GC, press Config and select the Handshaking menu item. Ensure that the following settings are made:

• Remote Start In should be *High to low. This allows the AutoDesorb to start the GC run.

• Inhibit Ready In should be *When low. This signal is not used.

• GC Ready Out should be *When high. This lets the AutoDesorb know when the GC is still running. If the
AutoDesorb waits and does not run additional samples while the GC is running.
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5.5 Running Samples

In Xcalibur, set up on or more GC methods and set up a sequence of one or more GC sample runs (figure below).

Figure 5.2: GC sequence in Xcalibur. Here is shown three GC runs using GC methods “normal” and “bakeout.”

In the TD software, set up your TD methods. You may create any number of methods: either a single method or
different methods for each sample (below figure). It can be useful to give your TD method files the same names as the
GC method files they are used with, but this is not required.
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Figure 5.3: Setting up TD methods in the TD Software. Here is shown setting up a TD method named “normal.mth.”

In the TD software, set up a TD sequence (below figure). To edit the sequence, choose Run > Run
Samples(s)... from the menu and then click View Sequence Table.... Typically, each line in the TD
sequence corresponds with a similar line in the GC sequence.

64 Chapter 5. Thermo Xcalibur Usage



SIS Thermal Desorption Software, Release 1.2.0

Figure 5.4: Setting up a TD sequence in the TD Software. This sequence has three samples at AutoDesorb tube
numbers #1, #2, and #3 and using TD methods of “normal.mth” and “bakeout.mth”.

In Xcalibur, begin running the GC sequence (Actions > Run Sequence... menu) (below figure). Ensure that
NO instrument is marked as the start instrument (the AutoDesorb is essentially the start instrument). The GC will
remain idle until it receives a Start Run contact closure from the AutoDesorb.
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Figure 5.5: Starting the GC sequence in Xcalibur.

Back in the TD software, toggle the Process Queue button to ON. The AutoDesorb will now begin the desorption
process. Upon completion of TD, it will send a Start Run contact closure signal to the GC. The TD Software will
not begin the next thermal desorption run until it receives a READY signal back from the GC.
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Figure 5.6: Starting the TD sequence.

If you ever need to terminate the sequence, you must terminate both the TD and GC Sequences (terminate the thermal
desorption sequence first).

5.6 Additional Notes

Ensure that Prep Run Timeout (min) in the GC method is sufficiently high.

October 2005
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CHAPTER

SIX

CHEMSTATION/MASSHUNTER
MODIFICATIONS

The thermal desorption software interfaces to Agilent GC data system software (ChemStation or MassHunter) via
ChemStation/MassHunter macros. The thermal desorption software installs its own macro file (sistd.mac) into
the ChemStation/MassHunter program folder and may make a few other modifications to ChemStation/MassHunter
to allow it to use those macros.

You can use the Communications Parameters Tab (page 38) on the Configuration Window (page 36) to install or
uninstall these macros.

6.1 Technical Details

The following technical details are provided for reference and can be ignored by most users.

The installation places the TD macro file, sistd.mac, in the <CHEMSTATION>\msexe or
<CHEMSTATION>\core directory. <CHEMSTATION> is typically c:\msdchem, c:\chem32,
c:\gcms, or c:\hpchem. The uninstallation also edits the <CHEMSTATION>\msexe\user.mac or
<CHEMSTATION>\core\user.mac file to tell ChemStation/MassHunter to use the sistd.mac file.

Older versions of MS ChemStation (e.g. prior to G1701DA D.01.00sp1) do not support user.mac. Instead, the
installation modifies the following system macros:

• <CHEMSTATION>\msexe\top.mac

• <CHEMSTATION>\msexe\topmenu.mac

• <CHEMSTATION>\msexe\topmeth.mac

• <CHEMSTATION>\msexe\topenvbr.mac (if present)

All changes to the macros are enclosed in !***SISTD_BEGIN_MODIFICATIONS and
!SISTD_END_MODIFICATIONS comment tags and are therefore easily identifiable. Backups of your
original ChemStation macros will be placed in an <CHEMSTATION>\msexe\sistd_backup or
<CHEMSTATION>\core\sistd_backup directory.

If user.mac is used, ChemStation/MassHunter may generate a <CHEMSTATION>\X\hooks.ini (where X is
the instrument number) when it is run to register the hooks defined in user.mac. These hooks will be removed from
the hooks.ini file upon uninstallation.
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CHAPTER

SEVEN

SOFTWARE LICENSE AGREEMENT

Scientific Instrument Services, Inc.

Be sure to fill out and send in the enclosed registration card. This is required for technical support.

The information below includes important limitations to your right to copy or distribute any of the software included
on this disk or installed by this software. It informs you that the Software is protected under U.S. Copyright Law.
Licensee may copy it only to make a backup copy. If any component of this software is installed on more than one
computer you must license a separate copy for each user. If Licensee’s computer system is a local area network or wide
area network, Licensee must license those respective versions of the Software. If you do not agree with the terms and
conditions of this agreement, close this installation and return the complete package to Scientific Instrument Services,
Inc.

License: In consideration of payment for the purchase of this Software SIS grants to Licensee, a nonexclusive right to
use and display this copy of a the Software on a single computer, at a single location. If the single computer on which
you use the software is part of a network system, a separate License is required for each user on the network system.

Software Ownership: Licensee owns the physical media on which the software is originally or subsequently recorded
or fixed, but Scientific Instrument Services, Inc. retains title, ownership and copyrights of the software recorded on the
original disk copy(ies) and all subsequent copies of the Software or derivative works, regardless of the form or media
in or on which the original and other copies may exist. This License is not a sale of the original Software or any copy
thereof. You may not copy the disk(s), disk contents or accompanying printed material to sell, rent, lease, lend, or
otherwise distribute copies of the Software or included documentation to others.

Terms of Use: Licensee may use the Software on only one computer at a time. Licensee may not decompile, translate,
reverse engineer, or disassemble the Software, nor may Licensee create derivative works from it. Licensee may not
transfer the Software to anyone unless Licensee permanently transfers all copies of the Software in its possession, and
the recipient accepts all of the terms of this License. This License shall continue until Licensee returns the Software to
Scientific Instrument Services, Inc. or properly transfers or destroys all copies of the Software in Licensee’s posses-
sion. Scientific Instrument Services, Inc. may terminate this License at any time without notice if Licensee breaches
any of its terms.

Disclaimer: Scientific Instrument Services, Inc. makes no warranties, express or implied, with respect to the Software
or its quality, performance, merchantability or fitness for any purpose. The Software is licensed and delivered “as is”.

LIMITATION OF LIABILITY: In no event will Scientific Instrument Services, Inc. be liable for any direct, incidental,
indirect, special or consequential damages in connection whatsoever including , without limitation, damages for loss
of profits, business interruption, loss of information, data, sample material, or other pecuniary loss arising out of the
use of or inability to use the Software even if Scientific Instrument Services, Inc. has been advised of the possibility
of such damages. (Some states do not allow the exclusion or limitation of implied warranties, so the above limitation
may apply to varying degrees).

Scientific Instrument Services, Inc. warrants to the original Licensee the disk(s) on which the Software is recorded is
free from defects in materials and workmanship under normal use and service for a period of ninety (90) days from the
date of shipment. Further, Scientific Instrument Services, Inc. limits the duration of any implied warranty(ies) on the
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disk(s) including the warranties of merchantability and fitness for a particular purpose to the respective period stated
above.

Scientific Instrument Services, Inc.’s entire liability and Licensee’s exclusive remedy as to the disk(s) shall be, at Sci-
entific Instrument Services, Inc.’s option either return of the purchase price or replacement of the disk that does not
meet the aforementioned limited warranty and which is returned to Scientific Instrument Services, Inc. If failure of the
disk has resulted from accident, abuse, or misapplication, Scientific Instrument Services, Inc. shall have no responsi-
bility to replace the disk or refund the purchase price. Any replacement disk will be warranted for the remainder of
the original warranty period or 30 days, whichever is longer.

The above are the only warranties of any kind, either express or implied, including but not limited to the implied
warranties of merchantability and fitness for a particular purpose, that are made Scientific Instrument Services, Inc.
on the Software. No oral or written information or advice given by Scientific Instrument Services, Inc., its dealers,
distributors, agents, or employees shall create a warranty or in any way increase the scope of this warranty, and you
may not rely on any such information or advice.

This License is governed by the laws of the State of New Jersey, USA.

This software contains other components with their own copyright:

• Microsoft C/C++ runtime libraries - (c) Microsoft Corporation.

• Microsoft gdiplus.dll redistributable (installed on Windows 2000 only) may only be used with a validly licensed
Microsoft operating system.

• EnumSerialPorts Copyright (c) 1998 - 2013 by PJ Naughter
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EIGHT

SOFTWARE CHANGE LIST

This is a list of changes to the SIS Thermal Desorption software.

1.2.0 - 2014-02-26

This release adds support for Windows 7, ChemStation E.02.02, and MassHunter B.07 and drops support for very old
(pre-Windows 2000 systems). It also makes a variety of bug fixes and improvements to features and documentation.

• Windows 7 is now offically supported: (2012-12-14)

– Settings (sistd.ini), logs (default.log/debug.log), and the default method (default.mth) are now writ-
ten to the %ALLUSERSPROFILE%\SIS-TD folder, where %ALLUSERSPROFILE% is typically
c:\ProgramData on Windows 7 or c:\Documents and Settings\All Users on Win-
dows XP, Previously these were written to in the C:\Program Files*\SIS\TD folder. (or
C:\Users\<username>\AppData\Local\VirtualStore\Program Files\*\SIS\TD if
VirtualStore enabled on Windows 7). (2014-02)

– Fix Method Edit parameters panel invisible in Windows 7.

– Fix crash on method load/save dialog boxes.

– Fix “System > Run Samples (Sequence Table)” “Method” column corrupted.

• ChemStation compatibility (2014-02):

– ChemStation E.02.02.1431 supported (fixed “CF_Text” error in Data Analysis–described under
sistd.mac). E.02.00.493 (2008) was already supported.

– MassHunter B.07.00.1413 (Data Analysis F.01.00.1903) now supported.

– Autodetect c:\chem32 (newer GC ChemStation directory).

• Debug Log enhancements: (2014-02)

– The Configure dialog now displays the debug log path.

– New real-time Debug Log window, accessible from Configure dialog (View button) or Advanced Diag-
nostics.

– The “debug.log” file now includes time stamps and improved formatting.

– Any previous debug.log is renamed with a time stamp rather than overwritten on program startup. This
avoid losing debug log data upon program restart.

– Turning debug logging on/off now no longer requires a program restart or controller reset.

– Debug logging is now on by default. This can facilitate diagnostics.

• Configure dialog enhancement: (2014-02)
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– The serial port list now identifies which serial port numbers are found or not found on the system. This
avoids the user trying non-existent serial ports.

– Add Test button to test selected serial port.

– Add button to conveniently launch the Device Manager in the Windows Control Panel. This is useful for
displaying serial ports on the system as well.

– Most changes no longer cause the controller to reset. Exceptions include the serial port name.

– Configure Dialog: Chemstation Instrument #4 was mislabeled #3. (2014-02)

• More responsive when serial communication cannot be established: (2014-02)

– Make Reset button respond faster (e.g. 2 sec rather than 5-30 sec).

– Report a communication error faster when Reset fails to establish communication (e.g. 25 sec rather than
1 min).

– Close application faster (2 sec rather than 10 sec).

• ChemStation Integration and Macro (sistd.mac)

– Agilent MassHunter support. Tested on B.07.00.1413 (12-May-2013), with Data Analysis F.01.00.1903.

– ChemStation E.02.02.1431 support. Fixed “CF_Text” error observed in the Data Analysis status bar. This
error also caused the Thermal Desorption software to stop responding to ChemStation events after the
first sample in a sequence is run since ChemStation Instrument Acquisition macros invoke Data Analysis
(xdataanalysis command), which silently fails loading sistd.mac due to the CF_Text problem, thereby
clearing ChemStation hooks (hooks.ini file).

– Major structural changes to macro, for MassHunter support and cleanup. By default, DDE communication
is now disabled and all communication is via command line. MassHunter IA doesn’t support DDE, and
DDE connect is prone to freezing if -any- window is frozen (Microsoft KB136218).

– Fix - Fix DDE communication problem between some rare installations of ChemStation and the TD soft-
ware. Make DDE communication case insensitive. TD-I20070828

• Installation:

– Installer: confirm overwriting any preexisting settings (sistd.ini) or default method (default.mth). Do
not overwite any existing logs. Don’t delete these files on uninstall.

– Uninstall: Fix: Problems starting ChemStation after uninstall. Uninstall now removes customizations to
hooks.ini files. Without this, ChemStation may fail to start properly with an error like “ChemStation
did not complete its initialization cycle.” followed by displaying an “icstart*.log” containing near its bot-
tom “Macro: CHECKHOOK, Cmd: SISTD_load_method MSG: Undefined symbol: SISTD_load_meth”.
A workaround in previous versions was to delete the c:\msdchem\X\hooks.ini files for each in-
strument number X.

– Uninstall: automatically uninstall ChemStation/MassHunter macros and hooks.ini settings upon unin-
stall. Previously the user needed to disable ChemStation integration from the configuration dialog before
uninstalling.

– internal: remove winzip from setup.exe (internal).

– internal: smaller Perl.

• Runs:

– Add advanced option to prevent desorption blocks heaters from turning off during the run, in order to
reduce cycles times. This is documented in prevent-desorb-cooldown.txt. (2011-04-09)

– Prematurely terminate tube cool down (which by default is 5 min but can be globally adjusted) if desorption
blocks temperature is below 50 C. This is intended to avoid unnecessary delays under low temperatures.
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– Fix - The “System Limits” dialog box > “Tube cool down time” setting was being ignored. TD-I20110718

– Fix - Possible unspecific reporting of communication error type (2011-04-09)

– Fix - On attempt to prematurely stop the GC, TD possibly will advance prematurely prior to GC actually
stopping. (2011-04-09)

– Fix - Cleaner software shutdown. (2007-08-28)

• Advanced Diagnostics, Command Tester, and Debugging

– Add convenience controls for displaying and modifying current states and performing common commands.

– Always display latest TDSTATUS command and interpretation.

– Fix - “SIMULATOR” debug mode (in communication settings) sometimes gave random communication
errors after multiple resets due to multiple simulators being created simultaneously. (2014-02)

– Fix - “SIMULATOR” debug mode - gas pressure was not being simulated right.

• Title Bar and Other GUI

– Method Open/Save dialog boxes now default to current method path. (2012-12-14)

– Fix - Title bar was displaying method\default.m as the method name if the current ChemStation
method did not have TD settings (ads.mth file). This may have given the false impression that Chem-
Station and the TD software were not communicating. The TD software now displays the ChemStation
method name in this case and an asterisk (*) indicating that the TD settings are not saved in the current
ChemStation method.

– Fix - Asterisk (*) in title bar indicating method unsaved was not properly updated on using the “Method >
Import Method” menu.

– Display error on failure to write configuration settings (System Configure) in sistd.ini file or method
(ads.mth), as can occur due to Windows 7 permissions.

• Documentation:

– Add notes on compatibility of hardware and software.

– Expand/improve software documentation (sistd.chm/sistd.pdf).

– Software documentation now in Windows Help format (sistd.chm).

– Manual - Updated 5890 documentation (2006-02-17)

• Command line and data system interface (internal):

– New command line options in sistd.exe to send commands to currently running sistd.exe. Exam-
ple: sistd.exe method_path c:/MSDChem/1/methods/ method_file test.m tube
2 data_file 123.d gc_kill_time 60 loadmethod All poke variables: method_path,
method_file, tube, data_file, gc_kill_time. All execute commands: loadmethod, savemethod, prerun, com-
pletedrun, stoprun, printmethod, exit, hello Commands are normally sent via WM_COPYDATA but will
be sent via DDE if the “dde” command line option is specified before.

– New “hello” data system command (no-op function to test communication).

– New “printmethod” data system command to print TD method (currently disabled in sistd.mac).

– New “instok [n]” command line command to check whether the TD is enabled for ChemSta-
tion/MassHunter instrument number n.

– New “outfile” command line option for writing process exit code to a text file, such as for MassHunter
which can’t read process exit codes. sistd.exe outfile c:/temp/result.txt
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– New “uninstall” command line option, used by uninstaller to uninstalling ChemStation/MassHunter
macros.

– Allow passing command line arguments via new-line delimited text file (sistd.exe
@filename.txt) since older ChemStations limit command line length.

– DDE poke commands now remove up to two characters of whitespace rather than always removing exactly
two characters (cleaner and less ChemStation specific).

• Note: Some customers were provided 1.1.2-TEST* beta versions with some of the above fixes.

TD-I5 (firmware and software)

• Fix: Modifications to the desorption temperature program in a method during desorption does not always get
activated on the controller

1.1.1 - 2005-10-12

• Main points

– Added GC ChemStation G2070BA B.01.03 compatibility (and probably newer GC ChemStations as well)
(ref. issue # TD-I3)

– Added MS ChemStation G1701DA D.02.00sp1 compatibility. D.01.02sp1 and above now use the Chem-
Station hook mechanism.

– Significant improvements to the sequence table (for AutoDesorb systems without GC data system integra-
tion).

– New Method > Print Method... function in the TD software (note: not accessible from Chem-
Station though)

– AutoDesorb hardware tester now available from System > Manual Control...

– Added separate software manual.

– Fixed - debug.log now saved in correct location if sistd.exe started from a different directory.

• Sequence table window revamped (more robust GUI, input checking, and handing of disabled states on controls).

• When a sequence is non-empty, clicking the “Run” button now opens the sequence table rather than the single
run window.

• The sequence table is now be opened from the single sample run window. Run > Run Sequence... menu
item was removed.

• Added Method > Exit menu item.

• updates sistd-template.mac as described on TD-I3 for B.01.03 ChemStation compatibility.

1.1.0 - 2005-06

• incorporated TD5 simulator (serial port SIMULATOR)

• support for serial ports other than COM1-4 (FIX)

• reorganized directory structure

• refactored software (internal) structure, build system.

• command tester window better usability

• command-bar at bottom left of screen for special functionality (e.g. advanced diagnostics)

• “TD/Cryo-trap not detected” message changed to “TD/Cryo-trap not connected”

• merged limits.ini into sistd.ini
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• “manual control window” is now “run single sample” window and is accessible from the normal views via the
menu or toolbar.

• menus names changed: File –> Method menu items moved: items under “Window” moved to other menus.
Time/Temperature Settings moved to Method. new menu Status containing Instrument Status (Was Window >
Status) Sample Log Book (was in “Window”) renamed “Window” to “View”

• If TD5 is connected, then the carousel table of tubes does not display.

• min pressure to run minimum is now -10 psi rather than 0 (e.g. in case of offset)

• don’t display TD temp, desorb pressure and purge gas if TD is disconnected.

• gui - changed window title from “Scientific Instrument Services AutoDesorb” to “SIS AutoDesorb”

• disable editing of sample logbook (changes aren’t preserved anyway)

• new “Advanced Tab” in configuration window: enable/disable “debug logging”

• increased font size (10pt not 8pt)

• combined time and temperature settings windows into a single “TD Method” window.

• changed precision on numbers (e.g. temps are rounded to a degree rather than to a tenth of a degree)

• reworded text

• title bar: display “SIS Thermal Desorption” not “SIS AutoDesorb” and display software version number.

• removed log file selection in Sample Log Book.

• removed “copy” to clipboard control on sample log book

• log window now displays on run monitoring view

• retitled: data entry view to method edit view

• sistd.ini - Window Positions > Log changed to Window Positions > Logbook and format
changed to “left, top, right, bottom, visible” rather than “left, top, visible”

• [gui] Added SIS Logo on top right that links to help.

• [gui] status bar turns green when running

• [gui] sample log book can be resized

• prompt to save changed method before run single from td software.

• “Export method...” changed to “Import method...”

• no need to restart software on changing communications port or other system limits

• debug.log - encode non-printable chars

• moved default.m\ads.mth to method\default.mth

• renamed adstop.exe to sistd.exe

• in advanced config, added support for custom configuration commands on reinitialization

• F1 opens help

• “ChemStation Path” setting in sistd.ini

• renamed ads.ini to sistd.ini

• configure ChemStation instrument from software.

• change default max desorb temp from 300 to 400C.
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• pressure reading is zero-ed on initialization to correct any offset

1.0.3

• fixed solvent delay handling (only in G1701XX),

• added -4 deg undershoot for cryo-trap cooling, ...

1.0.2

• more ChemStation support, ...

1.0.1
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